ex 1250 no sound on both channel ouput

Moderators: Cameron Shoffner, Christian Cook, Kirk Fyvie, Martin Barbour, Gary Evans_QSC, QSC-Dale Sandberg


  • Hi im in trouble with my ex1250
    i have no sound at all that ouput on both chanell what it can be??? blown cap?
    weldingboy73
    Newbie
     
    Posts: 3
    Joined: Tue Dec 29, 2015 2:32 pm


  • There are a lot of possible causes for both channels to be non-functioning. There are many different symptoms to check for, such as if the amp shows any visible signs of life--i.e., the LEDs lighting and the fan running.

    I would suggest that you have it checked out by a qualified service technician. Let us know if you need a referral. Keep in mind that it's a pretty old amp; the EX Series was discontinued almost 20 years ago.
    Bob Lee
    Technical Communications Developer
    QSC, LLC
    Fellow, Audio Engineering Society
    Image
    "If it sounds good, it is good." —Duke Ellington
    User avatar
    Bob Lee
    QSC Audio Products
     
    Posts: 2518
    Joined: Thu Mar 06, 2003 2:01 am
    Location: Costa Mesa, California


  • ok thanks for the response :)

    the ampp start on with both green led on the front panel i can hear the clicking noise of the breaker

    when i apply a sound source i have nothing on the output i have played with the pot on the front still nothing what can i check in first?? :D

    p.s the fan spin really good lot of air
    weldingboy73
    Newbie
     
    Posts: 3
    Joined: Tue Dec 29, 2015 2:32 pm


  • Do you have a digital multimeter, an oscilloscope and an audio sine wave generator? And can you read schematic diagrams? Those would be the absolute minimum requirements for doing a basic signal flow check.
    Bob Lee
    Technical Communications Developer
    QSC, LLC
    Fellow, Audio Engineering Society
    Image
    "If it sounds good, it is good." —Duke Ellington
    User avatar
    Bob Lee
    QSC Audio Products
     
    Posts: 2518
    Joined: Thu Mar 06, 2003 2:01 am
    Location: Costa Mesa, California



Return to Power Amplifier Support




Information
  • Users browsing this forum: No registered users and 1 guest
cron