rmx 2450 input/output issue

Moderators: Cameron Shoffner, Christian Cook, Kirk Fyvie, Martin Barbour, Gary Evans_QSC, QSC-Dale Sandberg

Thu Jul 07, 2016 9:43 am

  • I have a rmx 2450 that has been in a permanent install for a few years. This past weekend, it would power on fine, fan running but no input signal led's would light up and no sound from outputs. Checked everything. Cables, Input Source. Everything. Any ideas?
    markbelldj43
    Newbie
     
    Posts: 2
    Joined: Thu Jul 07, 2016 6:04 am

Thu Jul 07, 2016 2:06 pm

  • The Signal LEDs indicate output, not input.

    I would suggest plugging an audio signal generator directly into the amp inputs and see if it produces anything when you turn up the amp gain controls, just to make sure that the amp actually responds to input signals. If it doesn't, you'll have to pull the amp out and check it out in more depth to see where the signal doesn't get through.
    Bob Lee
    Technical Communications Developer
    QSC, LLC
    Fellow, Audio Engineering Society
    Image
    "If it sounds good, it is good." —Duke Ellington
    User avatar
    Bob Lee
    QSC Audio Products
     
    Posts: 2518
    Joined: Thu Mar 06, 2003 2:01 am
    Location: Costa Mesa, California

Fri Jul 08, 2016 11:41 am

  • I've tried multiple signal sources into amp. tried xlr and 1/4 inputs thinking maybe it might be the inputs themselves. nothing. also opened up amp and looked around, nothing seems to have visibly 'blown' on the input board or anywhere else. puzzling. will try and locate an actual audio signal generator to use..
    markbelldj43
    Newbie
     
    Posts: 2
    Joined: Thu Jul 07, 2016 6:04 am

Mon Jul 11, 2016 9:27 am

  • Since neither channel passes audio, it's likely that the failure is in a circuit that affects both channels. The mute circuit is therefore a likely culprit.

    If you confirm that it's an internal fault, I'd suggest that you have a qualified tech check it out.
    Bob Lee
    Technical Communications Developer
    QSC, LLC
    Fellow, Audio Engineering Society
    Image
    "If it sounds good, it is good." —Duke Ellington
    User avatar
    Bob Lee
    QSC Audio Products
     
    Posts: 2518
    Joined: Thu Mar 06, 2003 2:01 am
    Location: Costa Mesa, California



Return to Power Amplifier Support




Information
  • Users browsing this forum: No registered users and 1 guest
cron